VMware is instructing users to be on the lookout for software patches for 31 products that are affected by two vulnerabilities associated with the Linux kernel implementation of TCP Selective Acknowledgement (SACK).

The two flaws, SACK Panic (CVE-2019-11477) and SACK Excess Resource Usage (CVE-2019-11478), were originally found and disclosed by Netflix researchers, along with two Linux bugs.

“These issues may allow a malicious entity to execute a denial of service attack against affected products, warns a July 2 company security advisory that collectively rates the vulnerabilities as important in severity. (SACK Panic has a CVSSv3 base score of 7.5, while SACK Excess Resource Usage has a score of 5.3.)

As of July 3, 11:30 a.m. ET, patches were available for SD-WAN Edge by VeloCloud, SD-WAN Gateway by VeloCloud, SD-WAN Orchestrator by VeloCloud, Unified Access Gateway and vCenter Server Appliance, and workarounds were available for Unified Access Gateway and vCloud Director for Service Providers.

Patches are pending for AppDefense, Container Service Extension, Enterprise PKS, Horizon, Horizon DaaS, Hybrid Cloud Extension, Identity Manager, Integrated OpenStack, NSX for vSphere, NSX-T Data Center, Pulse Console, Skyline Collector, vCloud Availability Appliance, vCloud Director For Service Providers, vCloud Usage Meter, vRealize Automation, vRealize Business for Cloud, vRealize Code Stream, vRealize Log Insight, vRealize Network Insight, vRealize Operations manager, vRealize Orchestrator Appliance, vRealize Suite Lifecycle Manager, vSphere Data Protection, vSphere Integrated Containers and vSphere Replication.