Adobe Systems today issued a significant update to its Acrobat and Acrobat Reader products for Windows and macOS, fixing 86 vulnerabilities, including multiple critical arbitrary code execution flaws.

The bugs consist of 22 out-of-bounds writes, 36 out-of-bounds reads, seven heap overflows, seven use-after-frees, three type confusions, one stack overflow, one double free, two integer overflows, three buffer errors, three untrusted pointer dereferences, and a security bypass.

In addition to code execution, some of these bugs can be exploited for information disclosure and privilege escalation.

Please register to continue.

Already registered? Log in.

Once you register, you'll receive:

  • News analysis

    The context and insight you need to stay abreast of the most important developments in cybersecurity. CISO and practitioner perspectives; strategy and tactics; solutions and innovation; policy and regulation.

  • Archives

    Unlimited access to nearly 20 years of SC Media industry analysis and news-you-can-use.

  • Daily Newswire

    SC Media’s essential morning briefing for cybersecurity professionals.

  • Learning Express

    One-click access to our extensive program of virtual events, with convenient calendar reminders and ability to earn CISSP credits.