Dell is reporting a high-rated vulnerability in its SupportAssist for business and home PCs that could result in remote code execution.

CVE-2020-5316 affects business PC versions 2.0 through 2.1.3 and home PC versions 2.0 through 3.4. Each contain an uncontrolled search path vulnerability that can be exploited by a locally authenticated low-privileged user to cause the loading of arbitrary DLLs by the SupportAssist binaries, resulting in the privileged execution of arbitrary code.

Dell has issued patches fixing the vulnerability and for those who do not have automatic updates enabled the company is recommending they update to Dell SupportAssist for business PCs version 2.1.4 Dell SupportAssist for home PCs version 3.4.1.

Please register to continue.

Already registered? Log in.

Once you register, you'll receive:

  • News analysis

    The context and insight you need to stay abreast of the most important developments in cybersecurity. CISO and practitioner perspectives; strategy and tactics; solutions and innovation; policy and regulation.

  • Archives

    Unlimited access to nearly 20 years of SC Media industry analysis and news-you-can-use.

  • Daily Newswire

    SC Media’s essential morning briefing for cybersecurity professionals.

  • Learning Express

    One-click access to our extensive program of virtual events, with convenient calendar reminders and ability to earn CISSP credits.