WordPress rolled out version 5.2.4 patching six vulnerabilities as a short-term fix prior to the release of version 5.3.

WordPress version 5.2.3 and earlier are affected by these bugs.

The problems covered included an issue where stored XSS could be added via the Customizer, a method of viewing unauthenticated posts, a way to create a stored XSS to inject Javascript into style tags, a method to poison the cache of JSON GET requests via the Vary: Origin header, a server-side request forgery in the way that URLs are validated and issues related to referrer validation in the admin area.

Please register to continue.

Already registered? Log in.

Once you register, you'll receive:

  • News analysis

    The context and insight you need to stay abreast of the most important developments in cybersecurity. CISO and practitioner perspectives; strategy and tactics; solutions and innovation; policy and regulation.

  • Archives

    Unlimited access to nearly 20 years of SC Media industry analysis and news-you-can-use.

  • Daily Newswire

    SC Media’s essential morning briefing for cybersecurity professionals.

  • Learning Express

    One-click access to our extensive program of virtual events, with convenient calendar reminders and ability to earn CISSP credits.