We’ve been encouraged by our friends at Mozilla to remind readers that support for Firefox 1.5 ends in mid-May.

Users are being asked to upgrade, if they have not done so already, to version 2.0, which contains built-in phishing protection.

Those looking to update can get the skinny here.

From a security standpoint, it’s always a good idea to update to the newest version of software as, chances are, the most recent installment contains less flaws and enhanced protection.

So update people, or you’re out of luck if you need troubleshooting. It only takes a couple minutes.